windows环境下,如何在Pycharm下安装TensorFlow环境

目录

前言:

最近由于工作需要要使用TensorFlow,所以只能狂补相关的知识。本来博主打算在Ubantu上玩,但是由于一些原因还是放弃了这个想法,就转移到Pycharm上来玩。以下是自己在收集资料的过程中看到一篇很好的安装教程,分享一下。

声明:
python版本和tensorflow版本之间有对应关系。如果搞不好,会出现各种问题。博主采用的是python3.7和tensorflow2.0。

1.安装Anaconda

选择相应的Anaconda进行安装,下载地址点击这里,下载对应系统版本的Anaconda。
这里写图片描述
就和安装普通的软件一样,全部选择默认即可,注意勾选将python3.6添加进环境变量。
这里写图片描述
这样Anaconda就安装好了,我们可以通过下面的命令来查看Anaconda已经安装了哪些包。
运行 开始菜单->Anaconda3—>Anaconda Prompt :

conda list

这里写图片描述
可以看到已经安装了numpy、sympy等常用的包。

2.安装Tensorflow

TensorFlow目前在Windows下只支持python 3.5版本。

(1)打开Anaconda Prompt,输入清华仓库镜像,这样更新会快一些:
这里写图片描述

conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/
conda config --set show_channel_urls yes

(2)同样在Anaconda Prompt中利用Anaconda创建一个python3.7的环境,环境名称为tensorflow ,输入下面命令:

conda create -n tensorflow python=3.7

运行 开始菜单->Anaconda3—>Anaconda Navigator,点击左侧的Environments,可以看到tensorflow的环境已经创建好了。

这里写图片描述

这里写图片描述

(3)在Anaconda Prompt中启动tensorflow环境:

activate tensorflow

这里写图片描述
注:当不使用tensorflow时,关闭tensorflow环境,命令为:deactivate

(4)安装cpu版本的TensorFlow

pip install tensorflow==2.0

注:这里没有介绍GPU版本的安装方法,GPU版本需要安装cuda8+cudnn5,如需要的请搜索其他博文。
注意:一定要在 刚刚创建的tensorflow的环境下安装!!!!

这样tensorflow cpu版本就安装好了。

(5)测试tensorflow
在Anaconda Prompt中启动tensorflow环境,并进入python环境。

测试代码如下:

import tensorflow as tf
#查看tensorflow版本
print(tf.__version__)

3.其他问题

安装tensorflow后报错:“DLL load failed: 找不到指定的模块”。
这类问题(pip安装完包之后再去引用报错:找不到执行模块)一般是由于版本冲突引起的。所以要考虑调整python或者tensorflow的版本。如果tensorflow是最新的2.3版本,可以考虑降低到2.0甚至1.X等。看问题是否能解决。

4.在pycharm中使用tensorflow

习惯了使用PyCharm来开发,配置如下:
新建工程后在
File-Setting–Project Interpreter选择tensorflow下的Python解释器,
例如我的解释器位置:
这里写图片描述
这里写图片描述
等部署完后便可跑个HelloWorld了

import tensorflow as tf
#查看tensorflow版本
print(tf.__version__)

运行一下

起飞!

这种方式的好处:不用每次都 开启、关闭环境了。
这里写图片描述
(activate tensorflow 、deactivate tensorflow)

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页